use strict;
my $str = ':60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456';
my $regex = qr/:60([FM]):([CD])\d{6}/mp;
my $subst = ':60$1:$2120412';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";