using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":60([FM]):([CD])\d{6}";
string substitution = @":60$1:$2120412";
string input = @":60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}