# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\+\b33|\b0)[67][0-9]{8}$//gm;t' <<< "+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211"