import Foundation
let pattern = #"^(\+\b33|\b0)[67][0-9]{8}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)