#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\+\b33|\b0)[67][0-9]{8}$"
Local $sString = "+33611223344+33611223344" & @CRLF & _
"0611223344 0744332211" & @CRLF & _
"0744332211+33611223344" & @CRLF & _
"0744332211 +33611223344" & @CRLF & _
"0611223344" & @CRLF & _
"0744332211" & @CRLF & _
"+33611223344" & @CRLF & _
"+33744332211" & @CRLF & _
"06112233440744332211"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)