using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+\b33|\b0)[67][0-9]{8}$";
string substitution = @"";
string input = @"+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}