const regex = /^(\+\b33|\b0)[67][0-9]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+\\b33|\\b0)[67][0-9]{8}$', 'gm')
const str = `+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);