import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+\\b33|\\b0)[67][0-9]{8}$";
final String string = "+33611223344+33611223344\n"
+ "0611223344 0744332211\n"
+ "0744332211+33611223344\n"
+ "0744332211 +33611223344\n"
+ "0611223344\n"
+ "0744332211\n"
+ "+33611223344\n"
+ "+33744332211\n"
+ "06112233440744332211";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}