$re = '/^(\+\b33|\b0)[67][0-9]{8}$/m';
$str = '+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;