re = /^(\+\b33|\b0)[67][0-9]{8}$/m
str = '+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344
0611223344
0744332211
+33611223344
+33744332211
06112233440744332211'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result