# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+\b33|\b0)[67][0-9]{8}$"
test_str = ("+33611223344+33611223344\n"
"0611223344 0744332211\n"
"0744332211+33611223344\n"
"0744332211 +33611223344\n"
"0611223344\n"
"0744332211\n"
"+33611223344\n"
"+33744332211\n"
"06112233440744332211")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.