use strict;
my $str = '1234';
my $regex = qr/(.)(.{3})\s*/p;
my $subst = '{{:achhd:katalog:$1:$1$2.png}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";