re = /(.)(.{3})\s*/
str = '1234'
subst = '{{:achhd:katalog:$1:$1$2.png}}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result