$re = '/(.)(.{3})\s*/';
$str = '1234';
$subst = "{{:achhd:katalog:$1:$1$2.png}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;