# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<br\s*\\/?>//gm;t' <<< "I have <br> <br asked br> <br />
a <br/> <h1>
<h1<br>>>>>>
<br>>>>>>>> question <b . <a"