use strict;
my $str = 'I have <br> <br asked br> <br />
a <br/> <h1>
<h1<br>>>>>>
<br>>>>>>>> question <b . <a';
my $regex = qr/<br\s*\/?>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";