import re
regex = re.compile(r"<br\s*\/?>", flags=re.MULTILINE)
test_str = ("I have <br> <br asked br> <br />\n\n"
"a <br/> <h1>\n\n"
"<h1<br>>>>>>\n"
"<br>>>>>>>> question <b . <a")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)