# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?//gm;t' <<< "image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100"