import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "wid=\\d+(\\.\\d)*(?:&crop=\\d+(?:\\.\\d+)?(?:,\\d+(?:\\.\\d+)?)*)?";
final String string = "image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0\n"
+ "image/hugoboss/test%2Dimg?wid=100";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}