const regex = /wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('wid=\\d+(\\.\\d)*(?:&crop=\\d+(?:\\.\\d+)?(?:,\\d+(?:\\.\\d+)?)*)?', 'gm')
const str = `image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);