package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?`)
var str = `image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}