#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?"
Local $sString = "image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0" & @CRLF & _
"image/hugoboss/test%2Dimg?wid=100"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)