$re = '/wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?/m';
$str = 'image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;