// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?").unwrap();
let string = "image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}