# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?"
test_str = ("image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0\n"
"image/hugoboss/test%2Dimg?wid=100")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.