using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"wid=\d+(\.\d)*(?:&crop=\d+(?:\.\d+)?(?:,\d+(?:\.\d+)?)*)?";
string substitution = @"";
string input = @"image/hugoboss/test%2Dimg?wid=100&crop=0.0,0.0,96.0,65.0
image/hugoboss/test%2Dimg?wid=100";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}