using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['-]\b[a-zA-Z])|(\b[a-zA-Z])";
string substitution = @"$1$2";
string input = @"i'm some text
this-should not match";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}