package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(['-]\b[a-zA-Z])|(\b[a-zA-Z])`)
var str = `i'm some text
this-should not match`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}