re = /(['-]\b[a-zA-Z])|(\b[a-zA-Z])/m
str = 'i\'m some text
this-should not match'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result