const regex = /(['-]\b[a-zA-Z])|(\b[a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\'-]\\b[a-zA-Z])|(\\b[a-zA-Z])', 'gm')
const str = `i'm some text
this-should not match`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);