use strict;
my $str = 'i\'m some text
this-should not match';
my $regex = qr/(['-]\b[a-zA-Z])|(\b[a-zA-Z])/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";