import re
regex = re.compile(r"(['-]\b[a-zA-Z])|(\b[a-zA-Z])", flags=re.MULTILINE)
test_str = ("i'm some text\n"
"this-should not match")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)