#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$"
Local $sString = "0" & @CRLF & _
"12" & @CRLF & _
"12.123" & @CRLF & _
"12,12" & @CRLF & _
"12," & @CRLF & _
"123." & @CRLF & _
"12,123,123.88" & @CRLF & _
"12,123,123.12456" & @CRLF & _
"12125457.22" & @CRLF & _
"1,1,1,1" & @CRLF & _
"1.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)