$re = '/^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$/';
$str = '0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;