package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$`)
var str = []byte(`0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}