const regex = /^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?\\d{1,3}(?:,\\d{3})*(?:[.]\\d{2})?$', '')
const str = `0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);