import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?\\d{1,3}(?:,\\d{3})*(?:[.]\\d{2})?$";
final String string = "0\n"
+ "12\n"
+ "12.123\n"
+ "12,12\n"
+ "12,\n"
+ "123.\n"
+ "12,123,123.88\n"
+ "12,123,123.12456\n"
+ "12125457.22\n"
+ "1,1,1,1\n"
+ "1.1\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}