using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$";
string substitution = @"$1$2$3$2$4";
string input = @"PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}