import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(PRO\\|)(\\d+\\|)([^|]+\\|)\\d+\\|(.*)$";
final String string = "PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|";
final String subst = "$1$2$3$2$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}