$re = '/^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$/m';
$str = 'PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|';
$subst = "$1$2$3$2$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;