package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$`)
var str = `PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|`
var substitution = "$1$2$3$2$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}