import re
regex = re.compile(r"^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$", flags=re.MULTILINE)
test_str = "PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|"
subst = "$1$2$3$2$4"
result = regex.sub(subst, test_str)
if result:
print(result)