// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$").unwrap();
let string = "PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|";
let substitution = "$1$2$3$2$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}