# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(video.*?)%7bmatch%7d/$1REPLACEMENT_HERE/g;t' <<< " video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length"