$re = '/(video.*?)%7bmatch%7d/';
$str = ' video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length';
$subst = "$1REPLACEMENT_HERE";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;