re = /(video.*?)%7bmatch%7d/
str = ' video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length'
subst = '$1REPLACEMENT_HERE'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result