package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(video.*?)%7bmatch%7d`)
var str = ` video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length`
var substitution = "$1REPLACEMENT_HERE"
fmt.Println(re.ReplaceAllString(str, substitution))
}