using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(video.*?)%7bmatch%7d";
string substitution = @"$1REPLACEMENT_HERE";
string input = @" video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}