const regex = /(video.*?)%7bmatch%7d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(video.*?)%7bmatch%7d', 'g')
const str = ` video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length`;
const subst = `$1REPLACEMENT_HERE`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);