use strict;
my $str = ' video://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length
audio://lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length/%7bmatch%7d/lots0fr@ndomcharact#Rsinbetweenof1nd1scrimin@length';
my $regex = qr/(video.*?)%7bmatch%7d/p;
my $subst = '$1REPLACEMENT_HERE';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";